Parent Project

Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 8
Number of dependencies (NOD): 36
Number of unique artifacts (NOA): 39
Number of version-conflicting artifacts (NOC): 2
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 92 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

commons-beanutils:commons-beanutils

[Error]
1.7.0
  1. org.apache.myfaces.trinidad:trinidad-blank:war:2.1.2-SNAPSHOT
    \- org.apache.myfaces.core:myfaces-impl:jar:2.1.6:provided
       \- commons-digester:commons-digester:jar:1.8:provided
          \- (commons-beanutils:commons-beanutils:jar:1.7.0:provided - omitted for conflict with 1.8.3)

  2. org.apache.myfaces.trinidad:trinidad-components-showcase:war:2.1.2-SNAPSHOT
    \- org.apache.myfaces.core:myfaces-impl:jar:2.1.6:provided
       \- commons-digester:commons-digester:jar:1.8:provided
          \- (commons-beanutils:commons-beanutils:jar:1.7.0:provided - omitted for conflict with 1.8.3)

  3. org.apache.myfaces.trinidad:trinidad-demo:war:2.1.2-SNAPSHOT
    \- org.apache.myfaces.core:myfaces-impl:jar:2.1.6:provided
       \- commons-digester:commons-digester:jar:1.8:provided
          \- (commons-beanutils:commons-beanutils:jar:1.7.0:provided - omitted for conflict with 1.8.3)

  4. org.apache.myfaces.trinidad:trinidad-example:pom:2.1.2-SNAPSHOT
    \- org.apache.myfaces.core:myfaces-impl:jar:2.1.6:provided
       \- commons-digester:commons-digester:jar:1.8:provided
          \- (commons-beanutils:commons-beanutils:jar:1.7.0:provided - omitted for conflict with 1.8.3)

1.8.3
  1. org.apache.myfaces.trinidad:trinidad-blank:war:2.1.2-SNAPSHOT
    \- org.apache.myfaces.core:myfaces-impl:jar:2.1.6:provided
       \- commons-beanutils:commons-beanutils:jar:1.8.3:provided

  2. org.apache.myfaces.trinidad:trinidad-components-showcase:war:2.1.2-SNAPSHOT
    \- org.apache.myfaces.core:myfaces-impl:jar:2.1.6:provided
       \- commons-beanutils:commons-beanutils:jar:1.8.3:provided

  3. org.apache.myfaces.trinidad:trinidad-demo:war:2.1.2-SNAPSHOT
    \- org.apache.myfaces.core:myfaces-impl:jar:2.1.6:provided
       \- commons-beanutils:commons-beanutils:jar:1.8.3:provided

  4. org.apache.myfaces.trinidad:trinidad-example:pom:2.1.2-SNAPSHOT
    \- org.apache.myfaces.core:myfaces-impl:jar:2.1.6:provided
       \- commons-beanutils:commons-beanutils:jar:1.8.3:provided

org.slf4j:slf4j-api

[Error]
1.4.2
  1. org.apache.myfaces.trinidad:trinidad-demo:war:2.1.2-SNAPSHOT
    +- org.slf4j:slf4j-api:jar:1.4.2:compile
    \- org.slf4j:slf4j-log4j12:jar:1.4.2:compile
       \- (org.slf4j:slf4j-api:jar:1.4.2:compile - omitted for duplicate)

1.5.6
  1. org.apache.myfaces.trinidad:trinidad-demo:war:2.1.2-SNAPSHOT
    \- org.hibernate:hibernate-validator:jar:4.0.0.GA:compile
       \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.4.2)