Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 22
Number of dependencies (NOD): 194
Number of unique artifacts (NOA): 207
Number of version-conflicting artifacts (NOC): 6
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 93 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

com.google.guava:guava

[Error]
12.0.1
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       \- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
          \- com.opera:operadriver:jar:1.5:test
             \- com.opera:operalaunchers:jar:1.1:test
                \- (com.google.guava:guava:jar:12.0.1:test - omitted for conflict with 18.0)

14.0
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       \- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
          \- com.opera:operadriver:jar:1.5:test
             \- (com.google.guava:guava:jar:14.0:test - omitted for conflict with 18.0)

18.0
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.shrinkwrap.resolver:shrinkwrap-resolver-impl-maven:jar:2.2.2:test
       \- com.google.guava:guava:jar:18.0:test

19.0
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       \- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
          +- org.seleniumhq.selenium:selenium-api:jar:2.53.1:test (version managed from 2.53.0)
          |  \- (com.google.guava:guava:jar:19.0:test - omitted for conflict with 18.0)
          \- org.seleniumhq.selenium:selenium-remote-driver:jar:2.53.1:test
             \- (com.google.guava:guava:jar:19.0:test - omitted for conflict with 18.0)

jaxen:jaxen

[Error]
1.0-FCS
  1. org.apache.myfaces.tobago:tobago-core:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- jaxen:jaxen:jar:1.1:provided
          \- (jaxen:jaxen:jar:1.0-FCS:provided - omitted for cycle)

  2. org.apache.myfaces.tobago:tobago-sandbox:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- jaxen:jaxen:jar:1.1:provided
          \- (jaxen:jaxen:jar:1.0-FCS:provided - omitted for cycle)

  3. org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT
    \- jaxen:jaxen:jar:1.1:compile
       \- (jaxen:jaxen:jar:1.0-FCS:compile - omitted for cycle)

1.1
  1. org.apache.myfaces.tobago:tobago-core:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- jaxen:jaxen:jar:1.1:provided

  2. org.apache.myfaces.tobago:tobago-sandbox:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- jaxen:jaxen:jar:1.1:provided

  3. org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT
    \- jaxen:jaxen:jar:1.1:compile

org.apache.commons:commons-exec

[Error]
1.1
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       \- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
          \- com.opera:operadriver:jar:1.5:test
             \- (org.apache.commons:commons-exec:jar:1.1:test - omitted for conflict with 1.3)

1.3
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       +- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
       |  +- org.seleniumhq.selenium:selenium-firefox-driver:jar:2.53.1:test
       |  |  \- org.apache.commons:commons-exec:jar:1.3:test
       |  \- org.seleniumhq.selenium:selenium-remote-driver:jar:2.53.1:test
       |     \- (org.apache.commons:commons-exec:jar:1.3:test - omitted for duplicate)
       \- org.seleniumhq.selenium:selenium-java:jar:2.53.1:test
          \- org.seleniumhq.selenium:selenium-edge-driver:jar:2.53.1:test
             \- (org.apache.commons:commons-exec:jar:1.3:test - omitted for duplicate)

org.apache.httpcomponents:httpclient

[Error]
4.5.1
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       \- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
          \- org.seleniumhq.selenium:selenium-remote-driver:jar:2.53.1:test
             \- org.apache.httpcomponents:httpclient:jar:4.5.1:test

  2. org.apache.myfaces.tobago:tobago-example-test:war:3.0.0-beta-2-SNAPSHOT
    \- org.seleniumhq.selenium:selenium-java:jar:2.53.1:test
       \- org.seleniumhq.selenium:selenium-chrome-driver:jar:2.53.1:test
          \- org.seleniumhq.selenium:selenium-remote-driver:jar:2.53.1:test
             \- org.apache.httpcomponents:httpclient:jar:4.5.1:test

4.5.2
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       \- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
          \- org.seleniumhq.selenium:htmlunit-driver:jar:2.20:test
             \- net.sourceforge.htmlunit:htmlunit:jar:2.20:test
                +- (org.apache.httpcomponents:httpclient:jar:4.5.2:test - omitted for conflict with 4.5.1)
                \- org.apache.httpcomponents:httpmime:jar:4.5.2:test
                   \- (org.apache.httpcomponents:httpclient:jar:4.5.2:test - omitted for conflict with 4.5.1)

  2. org.apache.myfaces.tobago:tobago-example-test:war:3.0.0-beta-2-SNAPSHOT
    \- org.seleniumhq.selenium:selenium-java:jar:2.53.1:test
       \- org.seleniumhq.selenium:htmlunit-driver:jar:2.21:test
          \- net.sourceforge.htmlunit:htmlunit:jar:2.21:test
             +- (org.apache.httpcomponents:httpclient:jar:4.5.2:test - omitted for conflict with 4.5.1)
             \- org.apache.httpcomponents:httpmime:jar:4.5.2:test
                \- (org.apache.httpcomponents:httpclient:jar:4.5.2:test - omitted for conflict with 4.5.1)

org.codehaus.plexus:plexus-utils

[Error]
1.4.5
  1. org.apache.myfaces.tobago:tobago-core:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- org.codehaus.modello:modello-plugin-java:jar:1.5:provided
          \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-30:provided
             \- (org.codehaus.plexus:plexus-utils:jar:1.4.5:provided - omitted for conflict with 1.5.8)

  2. org.apache.myfaces.tobago:tobago-sandbox:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- org.codehaus.modello:modello-plugin-java:jar:1.5:provided
          \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-30:provided
             \- (org.codehaus.plexus:plexus-utils:jar:1.4.5:provided - omitted for conflict with 1.5.8)

  3. org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT
    \- org.codehaus.modello:modello-plugin-java:jar:1.5:compile
       \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-30:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with 1.5.8)

1.5.8
  1. org.apache.myfaces.tobago:tobago-core:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- org.codehaus.modello:modello-plugin-java:jar:1.5:provided
          +- (org.codehaus.plexus:plexus-utils:jar:1.5.8:provided - omitted for conflict with 2.0.6)
          +- org.sonatype.plexus:plexus-build-api:jar:0.0.7:provided
          |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:provided - omitted for duplicate)
          \- org.codehaus.modello:modello-core:jar:1.5:provided
             \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:provided - omitted for duplicate)

  2. org.apache.myfaces.tobago:tobago-sandbox:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- org.codehaus.modello:modello-plugin-java:jar:1.5:provided
          +- (org.codehaus.plexus:plexus-utils:jar:1.5.8:provided - omitted for conflict with 2.0.6)
          +- org.sonatype.plexus:plexus-build-api:jar:0.0.7:provided
          |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:provided - omitted for duplicate)
          \- org.codehaus.modello:modello-core:jar:1.5:provided
             \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:provided - omitted for duplicate)

  3. org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT
    \- org.codehaus.modello:modello-plugin-java:jar:1.5:compile
       +- (org.codehaus.plexus:plexus-utils:jar:1.5.8:compile - omitted for conflict with 2.0.6)
       +- org.sonatype.plexus:plexus-build-api:jar:0.0.7:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:compile - omitted for duplicate)
       \- org.codehaus.modello:modello-core:jar:1.5:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:compile - omitted for duplicate)

2.0.6
  1. org.apache.myfaces.tobago:tobago-core:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- org.codehaus.plexus:plexus-utils:jar:2.0.6:provided

  2. org.apache.myfaces.tobago:tobago-sandbox:jar:3.0.0-beta-2-SNAPSHOT
    \- org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT:provided
       \- org.codehaus.plexus:plexus-utils:jar:2.0.6:provided

  3. org.apache.myfaces.tobago:tobago-tool-apt:jar:3.0.0-beta-2-SNAPSHOT
    \- org.codehaus.plexus:plexus-utils:jar:2.0.6:compile

xml-apis:xml-apis

[Error]
1.3.04
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       \- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
          \- org.seleniumhq.selenium:htmlunit-driver:jar:2.20:test
             \- net.sourceforge.htmlunit:htmlunit:jar:2.20:test
                \- xalan:xalan:jar:2.7.2:test
                   \- xalan:serializer:jar:2.7.2:test
                      \- (xml-apis:xml-apis:jar:1.3.04:test - omitted for conflict with 1.4.01)

1.4.01
  1. org.apache.myfaces.tobago:tobago-example-demo:war:3.0.0-beta-2-SNAPSHOT
    \- org.jboss.arquillian.graphene:graphene-webdriver:pom:2.1.0.CR1:test
       \- org.jboss.arquillian.extension:arquillian-drone-webdriver-depchain:pom:2.0.0.Final:test
          \- org.seleniumhq.selenium:htmlunit-driver:jar:2.20:test
             \- net.sourceforge.htmlunit:htmlunit:jar:2.20:test
                \- xerces:xercesImpl:jar:2.11.0:test
                   \- xml-apis:xml-apis:jar:1.4.01:test