Portlet Bridge Versions

The Apache MyFaces Portlet Bridge consists of several project branches. Each project branch implements a distinct version of the bridge designed to support a specific Portlet and JSF version. Currently, there are three bridges, each targeting a specific portlet and JSF version pair. See the table below for the specific relationships. As portlet 2.0 is backwards compatible, the bridge built for the portlet 1.0 environment will run in a portlet 2.0 container. The same isn't (always) true for the portions of JSF the bridge depends on. For example, neither the 1.0.0 or 2.0.0 bridges will run in a JSF 2.0 environment. It is recommended that one use the distribution that best matches the versions running in your installation environment.

Portlet Bridge PB Distribution JSF Version Portlet Version Status Specification
Version 3.x MyFaces Portlet Bridge 3.0.0 2.0/2.1 2.0 alpha JSR pending
Version 2.x MyFaces Portlet Bridge 2.0.0 1.2 2.0 released JSR-329: Portlet 2.0 Bridge for JavaServer Faces 1.2
Version 1.x MyFaces Portlet Bridge 1.0.0 1.2 1.0 released JSR-301: Portlet 1.0 Bridge for JavaServer Faces 1.2